Solution for yum problems on new CentOS 6 + WHM installations

Recently I discovered problems trying to install anything using yum on new servers based on CentOS 6 (64-bit) + WHM/cPanel. I was trying to install subversion using yum:

yum install subversion

And I was getting following output:

Error: Package: subversion-1.6.11-7.el6.x86_64 (base)
           Requires: perl(URI) >= 1.17
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
bandmin-1.6.1-5.noarch has missing requires of perl(bandmin.conf)
bandmin-1.6.1-5.noarch has missing requires of perl(bmversion.pl)
bandmin-1.6.1-5.noarch has missing requires of perl(services.conf)
exim-4.77-1.x86_64 has missing requires of perl(SafeFile)
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0

And I would get that trying to install just about anything with yum or by calling yum check.

To solve this problem you will have to open /etc/yum.conf for editing and to locate perl* in exclude= line and remove it (just perl* part). Now install anything by running the yum install package_name it will solve all those problems that you had! Once the installation is done and problems are solved, don’t forget to put perl* back to /etc/yum.conf in exclude= list!

This post helped you out? Why not buy me a coffee?

Amount
Your message for me
Tags: frontpage-2002-sr1 2 i386 has missing requires of libexpat so 0, bandmin-1 6 1-5 noarch has missing requires of perl(bandmin conf), ** found 29 pre-existing rpmdb problem(s) \yum check\ output follows:, Error: Package: mod_passenger-5 0 30-8 el6 x86_64 (passenger) Requires: httpd-mmn = 20051115
rrdtool not installing on cPanel
Solution for the custom fileds problem with WordPress 3.4.2

Comments

  1. How can i remove that do i need to use any ediotor to remove that line like vi /etc/yum.conf ??? and what about this command do this one help? yum –disableexcludes=main install git

  2. any text editor is fine… vi /etc/yum.conf would do just fine…

  3. Thank you. This worked perfectly. I wast trying to install git and it just wasn’t working. The one thing I was wondering is why perl should be excluded. Do you know why that would be?

  4. Worked great. Thanks for the tip.

  5. That was precise
    Thanks.

  6. CPanel has that perl exclude in yum.conf for a reason. CPanel ships their own version of perl and apparently the updated, sane version from the OS vendor doesn’t meet their requirements.

    Removing anything from the yum.conf exclude line and expecting CPanel to work (for some value of “work”) later on is very optimistic.

  7. HI, I get
    ** Found 6 pre-existing rpmdb problem(s), ‘yum check’ output follows:
    frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
    mod_hostinglimits-1.0-8.el6.cloudlinux.x86_64 has missing requires of httpd
    1:mod_ssl-2.2.15-15.el6_2.2.cloudlinux.x86_64 has missing requires of httpd
    1:mod_ssl-2.2.15-15.el6_2.2.cloudlinux.x86_64 has missing requires of httpd = (‘ 0’, ‘2.2.15’, ’15.el6_2.2.cloudlinux’)
    1:mod_ssl-2.2.15-15.el6_2.2.cloudlinux.x86_64 has missing requires of httpd-mmn = (‘0’, ‘20051115’, None)
    mod_wsgi-3.2-1.el6.x86_64 has missing requires of httpd-mmn = (‘0’, ‘20051115’,

    DOES THAT MEANS I do the same but with “httpd” ?

  8. not work for me

    I dont have perl* in that line:

    exclude=bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*

  9. Is there a way to get FrontPage installed back on the server via yum? It’s gone after a cpanel update.

Leave a Reply

Your email address will not be published / Required fields are marked *