Chrome just would not launch

Today something weird happened. I started up my computer and clicked on Chrome icon – and nothing. I click again nothing… This is weird… I start up Windows Task Manager and then I click again Chrome icon and I monitor Processes list at Windows Task Manager and chrome.exe doesn’t come up… So I start up Total Commander and go to c:\Users\USER\AppData\Local\Google\Chrome\Application\ and there is chrome.exe and there is debug.log. I start the chrome.exe and nothing again. In debug.log I’ve noticed lots of lines like this one:

[0214/035118:ERROR:client_util.cc(315)] Failed to load Chrome DLL from 0029F7E0
[0214/035118:ERROR:client_util.cc(356)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded

Also I see two directories above: /16.0.912.77 and /17.0.963.46. So this looks to me like some update gone wrong. I start Opera and start searching a at Google on how to solve this since I don’t want to loose all my logins, bookmarks etc… Few minutes later I have found a simple solution that worked but not fully… To solve this problem I had to copy the chrome.exe from /application folder into /application/17.0.963.43 folder (newer version folder). Then by running chrome.exe from that directory did start a browser but when I click on a Key (settings in Chrome) and go to “About Google Chrome” I can see error message “Update server not available (error: 1)” that means that my Chrome will not update itself in future.

So I went to FileHorse.com and downloaded the latest version of Google Chrome and at the moment it was 19.0.1036.7 and I start the chrome_installer.exe I just downloaded and nothing happens…. No installation stuff, nothing… Well I know Google guys like minimalism but this was nothing… but in my Google Application folder I see two new things: new folder /19.0.1036.7 and new file new_chrome.exe. So after trying few more things I found the solution. I had to delete old chrome.exe and rename new one from new_chrome.exe to chrome.exe and it was finally it!!! Chrome was working, update at about page is again saying “Google Chrome is up to date (19.0.1036.7)”.

Ok but why did this happen?
Well I started searching the web and I found out that this happened because of using Chromium or Chrome portable. And I’ve been using/trying both! So one of those probably started auto-update and than used settings stored in registry from my installed Chrome and messed it all up. So my advice for you today is: DO NOT use Chrome along with Chrome Portable or Chromium Portable or any other browser running on Chromium open-source platform!

Tags: could not find exported function relaunchchromebrowserwithnewcommandlineifneeded, Could not get Chrome DLL version, chrome not launching, chrome will not launch, failed to load chrome DLl, Google Chrome Not Launching, RelaunchChromeBrowserWithNewCommandLineIfNeeded, could not get chrome dll version could not find exported function relaunchchromebrowserwithnewcommandlineifneeded, yhs-fullyhosted_003, yhs-fh_lsonsw, block ad doubleclick net windows 7, google chrome will not launch, chrome is not launching, ctrl alt delete screen, ERROR:client_util cc(315), chrome does not launch, google chrome is not launching, why is chrome not launching, chrome browser not launching, [0905/193907:ERROR:client_util cc(327)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded, ERROR:client_util cc(327), algo-charter_if, Chrome Not Launching Windows 7, could not launch chrome, Google Chrome Does Not Launch, [0718/151726:ERROR:client_util cc(327)] Could not find exported function RelaunchChromeBrowserWithNewCommandLineIfNeeded [0730/110455:ERROR:client_util cc, application chrome exe, chrome doesnt launch, google chrome will launch, google chrome not responding while launching, google chrome relaunching fix, google chrome not working icon shows but not working when clicked on, google will not lautchh, google will not launch, google chrome will not launch?

7 thoughts on “Chrome just would not launch

  1. Rasmus Halland

    I experienced the same error after using Chrome Portable, and I found a solution. On startup, chrome non-portable will read the current version from the registry value HKEY_CURRENT_USER\Software\Google\Update\Clients\{8A69D345-D564-463c-AFF1-A69D9E530F96}\pv, and expects to be able to use that version string to find the rest of the chrome files.

    The problem with chrome portable is that it writes its own chrome version into that registry key when it runs. If that version is different from the non-portable chrome version, the non-portable chrome can’t fint its files.

    The fix is rather simple: Simply write your current non-portable chrome version to the registry value. The version can be seen in the chrome directory, which is %LOCALAPPDATA%\Google\Chrome\Application. Then it should be possible to start chrome again.

    This operation has to be performed every time the portable chrome has been used, so I created this powershell script, which does the job:

    $dir = dir “$($env:LOCALAPPDATA)\Google\Chrome\Application” | where { $_.name -match “^\d\d” } | sort -Property lastwritetime -descending | select -First 1
    if (-not $dir) {
    write-error “No chrome versions found.”
    }
    else {
    $ver = $dir.Name
    Set-ItemProperty -Path “HKCU:\Software\Google\Update\Clients\{8A69D345-D564-463c-AFF1-A69D9E530F96}” -Name pv -value $ver
    }

    Reply
  2. greg roberts

    This solution also works for people who expereience the same issue, but because of network redirected folders (Redirected App Data folders to be precise).

    Reply
  3. Michael Descamps

    I had a similar error message in the log file and I couldn’t start Chrome.
    My problem was solved by deleting the xml file in the Chrome application folder.

    Reply
  4. Dennis Kemp II

    over a year later…this last suggestion by Michael Descamps fixed my Chrome issue. My problem stemmed from a power outage. When I brought the computer back online, Chrome wouldn’t open…it would hang. I moved the XML file to my documents folder, just in case I was going to need to put it back in C:\Users\{username}\AppData\Local\Google\Chrome. Chrome now opens fine…and no errors.

    Reply
  5. steve

    First google restrict extensions for non google chrome browser but based on chrome and now gogle chrome web browser WON’T LAUNCH !!! I just can’t believe that !!! We should hurting google a loot !!!

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>